XMB Forum Software
Not logged in [Login - Register]
Go To Bottom

Printable Version  
Author: Subject: [In Progress] Will XMB 1.9.11 Work with PHP 7.4?
Carolyn
Experienced
**




Posts: 4
Registered: 6-15-2002
Member Is Offline

Mood: No Mood

[*] posted on 1-9-2021 at 06:24 PM
[In Progress] Will XMB 1.9.11 Work with PHP 7.4?


Full Board URL: http://www.asjcollection.com/board/
XMB Version: 1.9.11

I've been using XMB on my forum since 2002 and, since 2010, I've been using a version of 1.9.11. It hasn't given me any problems in over a decade, so I haven't updated. My server host has announced that they will be moving to PHP 7.4 in February. Is this going to cause any problems for my XMB forum?

Thanks to those of you who are keeping XMB going!
View user's profile Visit user's homepage View All Posts By User
lottos
Administrator
********




Posts: 412
Registered: 6-3-2002
Location: Competitions Australia: https://www.lottos.com.au/
Member Is Offline

Mood: pass me a TimTam

[*] posted on 1-15-2021 at 03:17 AM


I honestly can't remember if it will. I think I'm more inclined to say it will as older versions of the xmb scripts make calls to magic quotes which later versions of php no longer support. Plus, the developer has stated that php7 is minimal reuirement for 1.9.12 [see https://forums.xmbforum2.com/viewthread.php?tid=777083]

Why not upgrade to 1.9.12?
View user's profile Visit user's homepage View All Posts By User
miqrogroove
XMB 1.9.12 Lead Developer
*********


Avatar


Posts: 405
Registered: 10-1-2002
Location: Florida
Member Is Offline

Mood: Past Three O'Clock

[*] posted on 1-16-2021 at 07:08 PM


1.9.11.15 (released in 2017) and higher are the only versions that work on PHP 7.

If you have an older 1.9.11 then you must get the newer files. This is explained here:

https://docs.xmbforum2.com/index.php?title=Upgrades
View user's profile Visit user's homepage View All Posts By User
Carolyn
Experienced
**




Posts: 4
Registered: 6-15-2002
Member Is Offline

Mood: No Mood

[*] posted on 1-16-2021 at 07:42 PM


Thank you for the replies, lottos and microgroove. I will upgrade ASAP. I don't know what version I have. The files say 1.9.11, so it may be the first release.




View user's profile Visit user's homepage View All Posts By User
miqrogroove
XMB 1.9.12 Lead Developer
*********


Avatar


Posts: 405
Registered: 10-1-2002
Location: Florida
Member Is Offline

Mood: Past Three O'Clock

[*] posted on 1-16-2021 at 08:50 PM


Good luck. It sounds like you just need to copy the new 1.9.11 files. If you need any more help, please provide your current PHP version.
View user's profile Visit user's homepage View All Posts By User
bfgadmin
Member
***




Posts: 50
Registered: 5-7-2020
Location: Pittsburgh, PA
Member Is Offline

Mood: Technical

[*] posted on 1-17-2021 at 08:55 AM


Nice job on the board, Carolyn!

We have plenty of space over on XMB Host for you to test (or even host) the configuration you described. All of our hosts presently have XMB 1.9.12 installed with the latest version of PHP/MySQL, and it works perfectly from what I can tell.

Our boards also include a layered anti-spam system that has managed to prevent 100% of attempted automatic registrations at XMB Host (and another site: BFG). It is a mixture of ReCAPTCHA V2/V3, the StopForumSpam database, along with a time-limited list of IP's taken from the network security appliance.

If you end up needing a hand, please let me know. :):xmb blue rsvd:



View user's profile Visit user's homepage View All Posts By User

  Go To Top

Powered by XMB 1.9.12
XMB Forum Software © 2001-2020 The XMB Group
[Queries: 16] [PHP: 25.3% - SQL: 74.7%]
free forum hosting