XMB Forum Software
Not logged in [Login - Register]
Go To Bottom

Printable Version  
Author: Subject: unusual url link test
lottos
Administrator
********




Posts: 410
Registered: 6-3-2002
Location: Competitions Australia: https://www.lottos.com.au/
Member Is Offline

Mood: pass me a TimTam

[*] posted on 10-7-2020 at 10:27 AM
unusual url link test


View user's profile Visit user's homepage View All Posts By User
miqrogroove
XMB 1.9.12 Lead Developer
*********


Avatar


Posts: 398
Registered: 10-1-2002
Location: Florida
Member Is Offline

Mood: Past Three O'Clock

[*] posted on 10-8-2020 at 12:38 PM


I'm surprised it works at all. The img code, for example, won't allow the colon character in a URL. And while many applications are sloppy with encoding special characters, the colon is officially unsafe. You can work around this by properly replacing the colon with %3A. That's not a good user experience though. Probably an old bug.
View user's profile Visit user's homepage View All Posts By User
miqrogroove
XMB 1.9.12 Lead Developer
*********


Avatar


Posts: 398
Registered: 10-1-2002
Location: Florida
Member Is Offline

Mood: Past Three O'Clock

[*] posted on 10-14-2020 at 10:57 PM


Taking another look at this tonight.

We have "Disable Smilies" as another workaround.

Some of the changes since 1.9.11 to accommodate square braces will help make this easier to fix. I'm not sure yet if it's a small fix or something that will wait for later.
View user's profile Visit user's homepage View All Posts By User
lottos
Administrator
********




Posts: 410
Registered: 6-3-2002
Location: Competitions Australia: https://www.lottos.com.au/
Member Is Offline

Mood: pass me a TimTam

[*] posted on 10-14-2020 at 11:02 PM


Quote: Originally posted by miqrogroove  
Taking another look at this tonight.

We have "Disable Smilies" as another workaround.

Some of the changes since 1.9.11 to accommodate square braces will help make this easier to fix. I'm not sure yet if it's a small fix or something that will wait for later.



First time I've come across it, but thought it should be mentioned in case it becomes more prevalent.
View user's profile Visit user's homepage View All Posts By User
miqrogroove
XMB 1.9.12 Lead Developer
*********


Avatar


Posts: 398
Registered: 10-1-2002
Location: Florida
Member Is Offline

Mood: Past Three O'Clock

[*] posted on 10-15-2020 at 01:51 AM


Fixed now. The remaining smilie is yours. Garbage in, garbage out. :D
View user's profile Visit user's homepage View All Posts By User
miqrogroove
XMB 1.9.12 Lead Developer
*********


Avatar


Posts: 398
Registered: 10-1-2002
Location: Florida
Member Is Offline

Mood: Past Three O'Clock

[*] posted on 10-15-2020 at 02:08 AM


I don't see anything broken by the new patch.

Just have to decide whether or not to tackle one more bug before releasing 1.9.12...

https://bugs.xmbforum2.com/view.php?id=622
View user's profile Visit user's homepage View All Posts By User
lottos
Administrator
********




Posts: 410
Registered: 6-3-2002
Location: Competitions Australia: https://www.lottos.com.au/
Member Is Offline

Mood: pass me a TimTam

[*] posted on 10-15-2020 at 04:16 AM


View user's profile Visit user's homepage View All Posts By User
miqrogroove
XMB 1.9.12 Lead Developer
*********


Avatar


Posts: 398
Registered: 10-1-2002
Location: Florida
Member Is Offline

Mood: Past Three O'Clock

[*] posted on 10-15-2020 at 12:41 PM


Whatever that's supposed to be, we don't support it unless it's inside a url tag.
View user's profile Visit user's homepage View All Posts By User
lottos
Administrator
********




Posts: 410
Registered: 6-3-2002
Location: Competitions Australia: https://www.lottos.com.au/
Member Is Offline

Mood: pass me a TimTam

[*] posted on 10-17-2020 at 12:05 AM


Facebook images out of the question [due to their timestamp at the end of the image type]?

Facebook link:
[img]https://scontent.fsyd4-1.fna.fbcdn.net/v/t1.0-0/p526x296/121123287_3671821399495581_8838941427616089861_o.jpg?_nc_cat=100&_nc_sid=730e14& _nc_ohc=CsumgbFlwQwAX83LwCS&_nc_ht=scontent.fsyd4-1.fna&tp=6&oh=001a8d63f18789389038dd2c88ac79c5&oe=5FB0EB74[/img]

Facebook link less timestamp, removed portion after .jpg but informs me as
[bad img]


Instagram test [from https://newscrewdriver.com/2018/07/18/embedding-an-instagram-post-with-bbcode-without-plugin/]:

media.jpg - 15kB
View user's profile Visit user's homepage View All Posts By User
lottos
Administrator
********




Posts: 410
Registered: 6-3-2002
Location: Competitions Australia: https://www.lottos.com.au/
Member Is Offline

Mood: pass me a TimTam

[*] posted on 10-17-2020 at 12:08 AM


hmmm, perhaps Insta's won't work after the 24th of this month: https://developers.facebook.com/docs/instagram/oembed.

BBcode for Facebook and Instagram, or members just download the image and upload is the alternative.
View user's profile Visit user's homepage View All Posts By User
miqrogroove
XMB 1.9.12 Lead Developer
*********


Avatar


Posts: 398
Registered: 10-1-2002
Location: Florida
Member Is Offline

Mood: Past Three O'Clock

[*] posted on 10-17-2020 at 09:45 AM


Quote: Originally posted by lottos  
Facebook images out of the question [due to their timestamp at the end of the image type]?


What you have there is simply a bad link. I can't even open it in my browser. It might be some form of hotlink protection on their CDN?
View user's profile Visit user's homepage View All Posts By User

  Go To Top

Powered by XMB 1.9.12
XMB Forum Software © 2001-2020 The XMB Group
[Queries: 16] [PHP: 35.7% - SQL: 64.3%]
Thanks to competitions website.