XMB Forum Software
Not logged in [Login - Register]
Go To Bottom

Printable Version  
Author: Subject: [Resolved] Copy Pasting Special Chars Blanks Post
Nica
Member
***




Posts: 6
Registered: 2-4-2011
Member Is Offline


[*] posted on 8-4-2013 at 09:27 PM
[Resolved] Copy Pasting Special Chars Blanks Post


Full Board URL: http://www.cerulean-sins.com
XMB Version: 1.9.11

Hey,

So I abhor that I can not figure this out myself, even if I do have some thoughts.

Basically the issue that the users are having is that as this is a role play forums, users type up large amounts of text in their desired text editors (word, notepad, etc) and then copy paste it into the textbox to post their new thread/reply. This includes a variety of bbcodes and text (html is turned off). Recently, I switched over from a shared hosting server onto my own cloud, and so the forum/site/content also moved to this new server. At this point, users discovered that when they copy paste, and then hit "reply" or "post" or "preview", their posts come up absolutely BLANK.

I have tested a little and noticed that if I write a single sentence and copy paste that, I usually have no issues, but the moment I have a carriage return/paragraph, the whole thing blanks out again. Others have said that other characters, like quotes, do the same thing. So I will assume that it is any special character that breaks it - which is simply unacceptable. However, I was not having this issue prior to the move.

This makes me think it is a server variable, or perhaps in the database - but what?! I thought all my server settings were identical though of course one might have been missed, and I'm a at a complete loss. Any thoughts?

Veronica
View user's profile View All Posts By User
lottos
Administrator
********




Posts: 422
Registered: 6-3-2002
Member Is Offline

Mood: pass me a TimTam

[*] posted on 8-4-2013 at 09:29 PM


If you have access to the old database, I would first compare the 'character set' between the old and new database.



View user's profile View All Posts By User
Nica
Member
***




Posts: 6
Registered: 2-4-2011
Member Is Offline


[*] posted on 8-4-2013 at 10:50 PM


The database is one and the same. It was transferred over to the new server. What is the default character set - if anyone could confirm for me, then I could at least check that?
View user's profile View All Posts By User
Mouser
XMB Contributor
********




Posts: 199
Registered: 4-14-2008
Member Is Offline

Mood: Christmasy. Yes, in September.

[*] posted on 8-5-2013 at 03:59 PM


For all tables, I have this "latin1_swedish_ci".
View user's profile View All Posts By User
Nica
Member
***




Posts: 6
Registered: 2-4-2011
Member Is Offline


[*] posted on 8-5-2013 at 05:33 PM


Switched it to latin1_general_ci and it works like a charm now. Whether it broke other things, I don't know... haha, but at least this issue seems resolved! Thanks! Glad it wasn't an actual bug.
View user's profile View All Posts By User
Mouser
XMB Contributor
********




Posts: 199
Registered: 4-14-2008
Member Is Offline

Mood: Christmasy. Yes, in September.

[*] posted on 8-5-2013 at 06:32 PM


If it was an XMB bug, it would have occurred not only on your forum ;)

Glad it's fixed! I'll mark tis thread as Resolved.
View user's profile View All Posts By User
Nica
Member
***




Posts: 6
Registered: 2-4-2011
Member Is Offline


[*] posted on 8-5-2013 at 09:50 PM


Crap allmighty. Spoke too soon. Apparently same issues. Trying to copy paste documents from microsoft word (with dashes, special characters, etc) and it still blanks out the post. I had only changed the general settings collation, but the tables were already latin1_swedish_ci as you said yours are. However, still bugging out. Not sure how to test further.
(Turning on debug doesn't seem to show anything relevant at all.)
View user's profile View All Posts By User
Nica
Member
***




Posts: 6
Registered: 2-4-2011
Member Is Offline


[*] posted on 8-6-2013 at 01:56 AM


My host helped me investigate and was able to narrow down that it was "the version of PHP that cause the issue was: version 5.4.17".
In case anyone else has this issue.

Veronica
View user's profile View All Posts By User
eman86
Member
***




Posts: 62
Registered: 6-4-2013
Member Is Offline

Mood: Excited

[*] posted on 8-6-2013 at 12:18 PM


so XMB isn't PHP 5.4 compatible then? I have PHP 5.4 on my development server, I'll take a test drive on this and see :)

rest assured XMB 2 will be compatible ;)



Next Gen of XMB in the workings...
View user's profile View All Posts By User
Mouser
XMB Contributor
********




Posts: 199
Registered: 4-14-2008
Member Is Offline

Mood: Christmasy. Yes, in September.

[*] posted on 8-6-2013 at 04:48 PM


Of course XMB supports PHP 5.4
This was NO PHP issue.
This was a charset issue in the database the user created. As you could read above :)

FYI; http://docs.xmbforum2.com/Webmasters/Installation/Requiremen...
View user's profile View All Posts By User
Adalberto
Member
***




Posts: 13
Registered: 5-19-2013
Location: MyHome
Member Is Offline


[*] posted on 8-8-2013 at 07:04 PM


Quote: Originally posted by Mouser  
Of course XMB supports PHP 5.4
This was NO PHP issue.


Mmm.. I'm not sure, I have all mysql tables "latin1_swedish_ci" and charset is correctly.

If I go in Administration Panel -> Translations and edit for example:
Phrase Name: addtime
and this translations window have special characters, I see correctly with php 5.3 or lower. I see blank window with php 5.4 or higher :umm:
View user's profile View All Posts By User

  Go To Top

Powered by XMB 1.9.12
XMB Forum Software © 2001-2021 The XMB Group
[Queries: 16] [PHP: 44.9% - SQL: 55.1%]