XMB Forum Software

[Inactive] After two clean attempts to install no luck (solved)

FJCastanedoJordan - 6-11-2018 at 12:11 AM

URL completa del foro: http://www.distribuidora3hp.com/forum/index.php
XMB Versión: 1.9.11

After two atempts to instal version 1.9.11 patch 15 I just coldn´t get it to run the first time.

All I get is this:
The system has failed to process your request. If you're an administrator, please set the DEBUG flag to true in config.php.

After turning on DEBUG mode in Config.php it keeps telling me the same line above.

I have a 1.9.11 version installed at another dir in the web server and runs ok. I just haven´t gone public yet.
Just wanted to install the latest patch from zero to reset all changes I made to the other one.

The frist attempt froze qhen checking the installation requirementes and it never got to build the database completely. Only the information schema got build.

After debugging I changed the following in mysqli.php:

PHP Version on my Web server: 5.3.29

Bugs encountered and fixed:

File: mysqli.php

Line 302:
Change from: if ( ( $warnings = $query2->fetch_row()[0] ) > 0 ) { This requires PHP version 5.4 or newer
to: if ( ( $warnings = $query2->fetch_row() ) > 0 ) {

Line 378
Change from: $return = $query->fetch_array()[$field]; This requires PHP version 5.4 or newe
to: $return = $query->fetch_array($field);

After that it just keeps giving the error I first mentioned.

I even tried to upgrade the forum but to no avail.

Any help would be appreciate it.
--------------------------------------------------------------------------------
Added later: The above "bugs" are not bugs at all. The original syntax is correct. I just forced the code not to give an error but it does not work as expected. The reason is explained in the next message.

FJCastanedoJordan - 6-11-2018 at 12:41 PM

From what I read on the internet, this is (might be) an issue of not having the right version of PHP installed on the web server that hosts my site.

The version of PHP installed is 5.3.29

The version needed for the mysqli.php to work must be 5.4 or newer.

What I did, was to substitute both files mysql.php and mysqli.php with a copy of a previous install of XMB. It was installed in 2015 and although is version 1.9.11, it is an older patch, so I figure that the files affected must conform to PHP 5.3.29 in this older patch.

Since that version does not have a mysqli.php file I just made a copy of mysql.php and rename it to mysqli.php.

The XMB forum finally got up and ran.

NOTE: Althought the problem seems to be solved I would avvise to test it further before using it with this "hack" to run a full working Forum. I will be testing it and post any finding.

miqrogroove - 9-17-2020 at 05:09 PM

This might need bug tracking. I don't know if there will be any more patches on 1.9.11 but it's supposed to work in all 5.x versions of PHP.

miqrogroove - 9-17-2020 at 06:04 PM

Here is the link for reference https://bugs.xmbforum2.com/view.php?id=593