XMB Forum Software
Not logged in [Login - Register]
Go To Bottom

Printable Version  
Author: Subject: [Resolved] Trying to upgrade from 1.9.5 to 1.9.11
Christina
Member
***




Posts: 25
Registered: 7-1-2012
Member Is Offline


[*] posted on 7-16-2012 at 06:14 PM
[Resolved] Trying to upgrade from 1.9.5 to 1.9.11


Full Board URL: http://exposure.cute-poison.org/
XMB Version: 1.9.5 SP1

What is the best way to go about upgrading from 1.9.5 to 1.9.11?

I'm planning on upgrading my forums and moving it to a different domain but I would like to keep all the members, posts, threads, and forums. I would also like it to be 1.9.11.

Any help is greatly appreciated. :)
View user's profile View All Posts By User
Mouser
XMB Contributor
********




Posts: 199
Registered: 4-14-2008
Member Is Offline

Mood: Christmasy. Yes, in September.

[*] posted on 7-17-2012 at 02:23 PM


More information is available over here :)

http://docs.xmbforum2.com/Webmasters/Upgrades

There you'll find your answer.


If you want to upgrade, and move...
I would say;

1. Close your forum, and set a message that you are performing an upgrade. User should be come back later.
2. Make a full backup of the files and database. Upload everything to the new domain.
3. Update config.php to reflect the new settings.
(4. Upgrade to XMB 1.8.* - If applicable)
5. Upgrade to XMB 1.9.11.13

Then you will always have your old forum as a backup.
You could then create a .htaccess file to redirect all users to the new domain.

Maybe even modify header.php to display a special message for those users (who visit you through the .htaccess redirect) as well, so that they know the URL changed.
(I've done the exact same two years ago)
View user's profile View All Posts By User
Christina
Member
***




Posts: 25
Registered: 7-1-2012
Member Is Offline


[*] posted on 7-18-2012 at 06:37 AM


Thanks for the reply! Where can I download 1.8.*? :)
View user's profile View All Posts By User
vamsee
Experienced
***


Avatar


Posts: 50
Registered: 1-5-2003
Member Is Offline

Mood: No Mood

[*] posted on 8-3-2012 at 06:28 AM


i dont understand why do you need 1.8 now, when your existing forum is 1.9.5 SP1




Life is taxing, and death is relaxing
Astrology in Modern World
View user's profile Visit user's homepage View All Posts By User
Christina
Member
***




Posts: 25
Registered: 7-1-2012
Member Is Offline


[*] posted on 8-16-2012 at 05:40 AM


Quote: Originally posted by vamsee  
i dont understand why do you need 1.8 now, when your existing forum is 1.9.5 SP1

It said to in the earlier post to upgrade to that version.

I've tried upgrading to the latest version of XMB from 1.9.5SP1 and it's not working. Any suggestions?
View user's profile View All Posts By User
lottos
Administrator
********




Posts: 439
Registered: 6-3-2002
Member Is Offline

Mood: pass me a TimTam

[*] posted on 8-16-2012 at 10:03 PM


Quote: Originally posted by Christina  
Quote: Originally posted by vamsee  
i dont understand why do you need 1.8 now, when your existing forum is 1.9.5 SP1

It said to in the earlier post to upgrade to that version.

I've tried upgrading to the latest version of XMB from 1.9.5SP1 and it's not working. Any suggestions?


No, it said to upgrade to 1.8 if "Upgrading from XMB 1.6 and older versions".

First suggestion is to be more specific than "it's not working".



View user's profile View All Posts By User
Christina
Member
***




Posts: 25
Registered: 7-1-2012
Member Is Offline


[*] posted on 8-18-2012 at 05:31 AM


The MySQL tables are all named different and what not. I'm trying to keep the posts, threads, and members when moving over the forums.
View user's profile View All Posts By User
Mouser
XMB Contributor
********




Posts: 199
Registered: 4-14-2008
Member Is Offline

Mood: Christmasy. Yes, in September.

[*] posted on 8-19-2012 at 09:31 PM


You got a screenshot of those tables?
I've done many upgrades, that sounds strange :)
View user's profile View All Posts By User
Christina
Member
***




Posts: 25
Registered: 7-1-2012
Member Is Offline


[*] posted on 10-20-2012 at 04:51 PM


Is there someone who could do the upgrade?
The old forums are http://www.exposure.cute-poison.org and the new one is http://www.exposureforums.org/

If there is someone who could assist in the upgrade (keep members, posts, threads, etc)... I would even be willing to pay. Please let me know!
View user's profile View All Posts By User
lottos
Administrator
********




Posts: 439
Registered: 6-3-2002
Member Is Offline

Mood: pass me a TimTam

[*] posted on 10-23-2012 at 09:45 PM


Quote: Originally posted by Christina  
Is there someone who could do the upgrade?
The old forums are http://www.exposure.cute-poison.org and the new one is http://www.exposureforums.org/

If there is someone who could assist in the upgrade (keep members, posts, threads, etc)... I would even be willing to pay. Please let me know!


If you have no takers here, I would suggest listing on a freelancing website.



View user's profile View All Posts By User
Mouser
XMB Contributor
********




Posts: 199
Registered: 4-14-2008
Member Is Offline

Mood: Christmasy. Yes, in September.

[*] posted on 10-23-2012 at 10:19 PM


I could assist free of charge.
If still necessary.
View user's profile View All Posts By User
lottos
Administrator
********




Posts: 439
Registered: 6-3-2002
Member Is Offline

Mood: pass me a TimTam

[*] posted on 12-2-2013 at 01:16 AM


Seems the forum owner has moved the forum and is running 1.9.11



View user's profile View All Posts By User

  Go To Top

Powered by XMB 1.9.12
XMB Forum Software © 2001-2021 The XMB Group
[Queries: 16] [PHP: 33.6% - SQL: 66.4%]